Jupiter News: Release Notes

Update

Jupiter News: Release Notes

Status: closed
Date:
Affected Components:
Great Red Dot App Web App Mobile App Linux Android IOS
Update

Jupiter v2.8 has been released! For a detailed inventory of changes and updates please review our release notes.

Root Cause

Here's an update!

Root Cause

asasdads