Performance Degradation Notification for EA 1
Incident
2025-11-04T18:53:00.0000000Z
Performance Degradation Notification for EA 1
Status: in progress
Start:
2025-11-04T18:51:00.0000000Z
Affected Components:
Europa
EA 1
Update
2025-11-04T18:51:00.0000000Z
2025-11-04T18:51:00.0000000Z
Jupiter Services are currently experiencing a degradation of service that may impact customers. If your service is impacted, then your organization will be notified. If you are unable to access your application and have not received a notification, please ensure your organization is not blocking mail from noreply@jupiter.com.
Investigating
2025-11-04T18:53:00.0000000Z
2025-11-04T18:53:00.0000000Z
Downgraded from Unavailable to Performance
Copyright (C) 2020,